注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

技术行者

时代的车轮在按照摩尔定律滚动。

 
 
 

日志

 
 

Linux下,安装mod_wsgi时,遇到的一些问题  

2011-07-07 12:59:00|  分类: Linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

1. 系统中找不到apxs可执行文件

使用yum或者rpm直接安装httpd的情况下,所安装的Apache Webserver并没有安装用于编译的mod.so的开发模块apxs。这个扩展需要通过安装httpd_devel来得到,例如:

yum install httpd-devel

同样,其它需要编译mod.so文件的情况,也需要安装httpd_devel。

 

2. 缺少各类.h文件,例如缺少python.h

直接通过yum安装的程序,不一定完全。

确认一下Python的开发包和MySQL的开发包安装了没有。

yum install python-devel mysql-devel



make > cc.txt 2>&1

 

 

 

  评论这张
 
阅读(316)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017